Wikinews:Water cooler/technical/archives/2009/November

From Wikinews, the free news source you can write!
Jump to navigation Jump to search


Twitter

Guys, check the application that sends new articles on the twitter account. The links are not even links ;) 88.218.137.160 (talk) 13:10, 1 November 2009 (UTC)

It's been fixed now. the wub "?!" 17:21, 1 November 2009 (UTC)
Fixed Yea. My bad. --ShakataGaNai ^_^ 17:27, 1 November 2009 (UTC)

Google News

Are we still being regularly listed in google news? According to this, not all of our articles are being listed. Tempodivalse [talk] 16:18, 1 November 2009 (UTC)

No. We're not. Google requires we have a 3 digit number with each article, which is where curid came in. For the last many lengths of time, any link to ?curid= are nobot/index. The only links that will show up on Google are leads (Links on the main page not DPL) with at least 3 numbers/symbols. Sometimes 2 numbers is enough, but it is supposed to be 3, so I dunno. --ShakataGaNai ^_^ 17:29, 1 November 2009 (UTC)
Amgine is working hard to try to get a solution for this. See https://bugzilla.wikimedia.org/show_bug.cgi?id=20818 Bawolff 00:50, 2 November 2009 (UTC)
Note we now have a temporary really ugly kludge of a solution in place. Hopefully the bug will be fixed soon. Bawolff 15:25, 6 November 2009 (UTC)

Ugly Ass central site notice

Apparently the WMF likes to rub it into everyone else face that we're not Wikipedia. I've got nothing against raising money, because we cost money to stay on the air, but that thing is fucking hideous. No offense to whom ever "designed" that concept... For those of you who don't appreciate the giant mess on your screen, add the following to your personal CSS files:

#centralNotice { display: none !important; }

Really, if I had my druthers, I'd make some "adjustments" to Mediawiki:Common.css to help fix that fugly banner. Here's what I was thinking:

#centralNotice { font-size: 60%; }
#center-logo { display: none !important; }

I was warned that futzing with the banner could end "poorly" (not that I've ever cared about the consequences), so here's one better. What does the community think? Should we keep it as it? Should be make it less annoying (smaller) or should we remove it all together (until _they_ make it less annoying)? --ShakataGaNai ^_^ 07:15, 11 November 2009 (UTC)

Shaka, it's broken. I'm using IE on Windows - the world's most common combination - and the link is unclickable. On that basis, it needs to come down right now and I'd do it myself if I knew/understood MW well enough. Once, and only once, they fix that issue with it we put it back for the vote. BTW, I vote for removal when that time comes. We cannot have our site paraded round with a broken link being the very first thing that greets people. Blood Red Sandman (Talk) (Contribs) 07:29, 11 November 2009 (UTC)

Seconded, can't be clicked, looks awful; please remove as quickly as possible. It's not even our logo for crying out loud. Until they make a nice one, get rid of it.   Tris   10:09, 11 November 2009 (UTC)
I'm whinging to ComCom on your behalf. --Brian McNeil / talk 10:51, 11 November 2009 (UTC)
Oh god. I saw the proposed banner on meta and thought it was awful, but I assumed they would take account of some of the feedback there. Or at least use the right logo and a working link! I'll back completely anyone who removes it, Foundation permission or not. the wub "?!" 11:56, 11 November 2009 (UTC)

#centralNotice { font-size: 60%; font-variant: small-caps; } #center-logo { image: url("http://upload.wikimedia.org/wikipedia/commons/thumb/2/24/Wikinews-logo.svg/50px-Wikinews-logo.svg.png"); }

That keep everyone happy? Someone tell me what the 'standard' css is for the fugly one and I'll do something better. --Brian McNeil / talk 12:30, 11 November 2009 (UTC)
  • Noticed one little problem - the "hide" button is microscopic. --Brian McNeil / talk 12:32, 11 November 2009 (UTC)
Not working for me, it still shows the Wikipedia logo despite plenty of hard refreshing/purging. :( the wub "?!" 12:44, 11 November 2009 (UTC)
I can't see the banner, Brianmc's fix must have worked for me. Isn't this is something like what the banner looks like? Utterly hideous, it was a good idea to take it down. I wonder if the folks from the foundation are going to complain. Tempodivalse [talk] 14:21, 11 November 2009 (UTC)
  • My attempted fix didn't work. I was trying to figure out the CSS to substitute the image in my userspace when someone took the central notice down. --Brian McNeil / talk 14:25, 11 November 2009 (UTC)

Discussion moved to Wikinews:Fundraiser and Wikinews talk:Fundraiser

This needs to be sorted out and made damn sure never to happen again. --Brian McNeil / talk 17:16, 11 November 2009 (UTC)

Redlinks where they shouldn't be - WTF?

What's going on?

I opened up an old article just now, only to find that links piped to Wikipedia were instead formating themselves as local redlinks. The page was Driver hits median strip, rolls vehicle in NSW, Australia. Anyone else see this? Blood Red Sandman (Talk) (Contribs) 18:48, 12 November 2009 (UTC)

Interwiki's broken. Known issue. --ShakataGaNai ^_^ 18:49, 12 November 2009 (UTC)
First I've seen it. Blood Red Sandman (Talk) (Contribs) 18:53, 12 November 2009 (UTC)

Articles bumped to top of main page DPLs if {{published}} is removed

I've noticed that, every time a vandal blanks a published/sighted article, and it gets reverted, it bumps the article to the top of the main page DPLs - even if it's several days old. I've had to add Category:Archived to one article today to get it off of the lists. I see a potential for abuse here - a vandal can easily disrupt the display list by removing the publish tag on old articles. Even if the edit remains unsighted and is reverted, it will stay on the top of the DPL. One way to bypass this is to do what i did - add the archived category, despite the article not being archived - but is there a more convenient solution to this? Tempodivalse [talk] 03:25, 11 November 2009 (UTC)

  • I believe there is a bug outstanding for this - something Flagged Revisions doesn't quite yet handle. --Brian McNeil / talk 03:46, 11 November 2009 (UTC)
Flagged revs should have fixed this (this is a long standing issue though) See bugzilla:20813. Bawolff 20:11, 11 November 2009 (UTC)
I'm pretty sure some semi-auto scripts for adding things like categories in bulk to archived articles had a tendancy to push them into becoming the latest in the DPLs. FlaggedRevs can't stop that. Blood Red Sandman (Talk) (Contribs) 11:14, 14 November 2009 (UTC)

Article failed put back up for review not showing up correctly

Two Azerbaijani bloggers jailed failed because France 24 decided to move the URL and hence not all content was verifiable. That corrected, I manually changed to {{review}}, and whilst the article showed up in the Newsroom as requiring a review, it did not come up in the list of articles to be reviewed that one sees as an editor. I undid the change, replaced the re-review with issues tag to {{developing}} then used the javascript button to move back to {{review}}. Again, the article is in the Newsroom, but not in the site-wide list of articles to be reviewed. --Александр Дмитрий (Alexandr Dmitri) (talk) 05:26, 14 November 2009 (UTC)

The review alert gadget puts a limit of maximun showing 7 stories at once (to prevent say some vandal putting 200 articles up for review). (I'll try to make it show a more link when it does this). Bawolff 05:56, 14 November 2009 (UTC)
I wondered if that might be the case, which is why I started attacking the backlog. I see the "More >" link now. Thanks! --Александр Дмитрий (Alexandr Dmitri) (talk) 06:26, 14 November 2009 (UTC)

New RC patrolling concept

Hello, is there any needs to add the site in https://bugzilla.wikimedia.org/show_bug.cgi?id=21517? JackPotte (talk) 15:43, 15 November 2009 (UTC)

Don't we already have that? Something very simlar, anyway. I'm not sure anybody even uses it. Blood Red Sandman (Talk) (Contribs) 16:44, 15 November 2009 (UTC)
  • We have it. However, it is tied to Editor status. --Brian McNeil / talk 19:37, 15 November 2009 (UTC)

We've got FlaggedRev's for the articles, and don't have that much other vandalism... because we don't have that many edits. I think we're good w/o. --ShakataGaNai ^_^ 16:43, 17 November 2009 (UTC)

Odd bug when trying to edit an article marked for review

This has happened to me a number of times: when I click on the Edit link next to the title on an article tagged {{review}}, instead of allowing me to edit the body text, it opens up the Sources section. I have to use the Edit tab on the top of the page to edit the entire article instead. System Win XP SP3 with Firefox latest version. --Александр Дмитрий (Alexandr Dmitri) (talk) 18:54, 18 November 2009 (UTC)

Strange, that has never happened to me. Quick question: are you using the "edit link to edit lead" gadget in Special:Preferences? That might have a few bugs in it. Tempodivalse [talk] 18:56, 18 November 2009 (UTC)
Is this re-producible? (can you give me a page where this always happens? and the url that the link in question directs you to when it goes to the wrong section). The gadget does what is does in an extremely convuluted way, (It creates a new link element thats a copy of another link item, than tries to insert it early in the document, and than changes the url of the copied link. If i was doing it, i'd just create a new link, and set the url apropriatly). This could do this if for some reason it copied multiple links instead of just one. (not sure under what circumstances this would happen. maybe if there was a link in the sources header). Bawolff 22:10, 18 November 2009 (UTC)
Yes to Tempodivalse, and if it happens again I'll report the exact circumstances (links etc.) for Bawolff. It was driving me nuts for a couple of days, but has been behaving itself since. --Александр Дмитрий (Alexandr Dmitri) (talk) 09:37, 20 November 2009 (UTC)

Social bookmark - bug

Just got a bug with the {{social bookmarks}} template...

This article (Orange Telecom and the €160,000 bill) also gave problems with WN:ML, so it may be its formatting. --Brian McNeil / talk 12:11, 19 November 2009 (UTC)

Facebook has crappy utf-8 support. Its probably choking on the € sign. This is probably not a bug on our end (there was actually a wikitech-l thread a while back about this issue) . If you use a url without the euro sign in it, [1] it seems to work fine. Theoretically we could try to detect when we use unicode characters, and send an alternate form of the url to facebook. Bawolff 12:26, 19 November 2009 (UTC)
Twitter has the same problem. The en_wikinews feed came up with a "?" for the Euro symbol on the same story. --Brian McNeil / talk 12:32, 19 November 2009 (UTC)
Thats more likely an issue with ShakataGaNai's bot than twitter, since twitter definitly works in non-ascii languages. Bawolff 12:44, 19 November 2009 (UTC)
  • Welcome to Wikinews; this is not the bot you are seeking. :-P --Brian McNeil / talk 13:16, 19 November 2009 (UTC)
Bawolff is correct, the problem is in my bot. It doesn't handle anything outside of ASCII with any grace. Welcome to PHP, it doesn't do UTF (easily). Eventually I'll fix it, but a stray questionmark in one entry out of every 100 or so... isn't high on the priority list. --ShakataGaNai ^_^ 18:23, 20 November 2009 (UTC)

type=breaking in leads

I've noticed that some people have been complaining on the RC that putting a lead with type=breaking (And i assume by extension, type=urgent and similiar things) messes up spacing on the main page. Should i disable use of the type parameter in WN:ML? Bawolff 04:37, 20 November 2009 (UTC)

No. Tell them to screen shot it and report it somewhere. Here, or my talk page. I'll check it out and fix the templates as needed. --ShakataGaNai ^_^ 18:24, 20 November 2009 (UTC)

MakeLead generic image list

Wikinews:Make lead now tries to determine what image it should use for an article, if the article has no images, by what categories/infoboxes its in. It takes any category directly specified (aka [[category:Foo]] is recognized, but a category thats on the page as a result of a template being included is not). It considers any template without parameters to be an infobox. infoboxes currently take precendence over categories. The current map from infoboxes to category is very sparse, and is as follows:

Bawolff.leadGen.imgMap = {
 "UK" : "Flag of the United Kingdon.svg",
 "United Kingdom": "Flag of the United Kingdom.svg",
 "United States": "Flag of the United States.svg",
 "Canada": "Flag of Canada.svg",
 "Mexico": "Flag of Mexico.svg",
 "Computing": "Computer-aj aj ashton 01.svg",
 "Google": "Google logo png.png",
 "Obituary": "Wikinews tag obituary.png",
 "Science and technology infobox": "Science-symbol-2.svg",
 "Science and technology": "Science-symbol-2.svg" }

So for example, the first entry on this list, namely:

"UK" : "Flag of the United Kingdon.svg",

will associate image:Flag of the United Kingdom.svg with any article (provided it doesn't have any other images) if the source of the article contains one of: {{UK}}, {{uK}}, [[category:UK]], [[Category:uK]] [[category:UK|foo]] etc (obviously there is no category UK, but for many of these entries, the category and infbox name are the same, so i thought it'd be better to just have one list).

I would really appreciate help with making this list more complete. Bawolff 20:10, 28 November 2009 (UTC)

Sure, where's the list? I think WN:ML is infrequently enough used that the list can be a separate page. --Brian McNeil / talk 20:36, 28 November 2009 (UTC)
The list is currently in User:Bawolff/sanbox/leadGenerator.js (near the top). Bawolff 20:41, 28 November 2009 (UTC)
Just as a note, to anyone who edits this: Make sure that every line (except of the last line) ends in a comma, and that the template name starts with a capital letter. Bawolff 20:46, 28 November 2009 (UTC)
Also, anyone who wants something added and doesn't feel comfortable editing the script directly, should feel free to list it here, and I'll add copy it to the script. Bawolff 13:48, 30 November 2009 (UTC)